Mac python3 SSL问题解决:pip is configured with locations that require TLS/SSL

解决方案1.没有安装openssl2.切换你的openssl版本3.然后pip3 安装你需要的软件
返回SSL,openssl,安装,Mac,python3常用代码示例代码片段

解决方案

1.没有安装openssl

  1. >brew install openssl

2.切换你的openssl版本

  1. //100是随便输入的一个数字版本,是为了查到系统可用的openssl版本
  2. > brew switch openssl 100
  3. Error: openssl does not have a version "2.6.5" in the Cellar.
  4. openssl's installed versions: 1.0.2s //这个就是我们需要的版本号
  5. //正式安装
  6. >brew switch openssl 1.0.2s

3.然后pip3 安装你需要的软件

原文链接:https://rumenz.com/examples/python3/mac-python3-require-tls-ssl.html

【Linux常用命令速查手册】关注【入门小站】,后台回复 「1001」 自取。

点击下面标题即可获取对应PDF资料
↑回到顶部↑
入门小站 @2018